GPU rendering issues???

Discuss features and report problems with BlackInk
User avatar
jakekulp
 
Posts: 5
Joined: 06 Sep 2013, 22:27

GPU rendering issues???

Postby jakekulp » 06 Jun 2016, 03:26

Hey there, I'm having some issues with Black Ink not properly saving my work when I'm running the program in DirectX10 Or Directx11.

When I save my images they are full of glitched squares. Running the program in DirectX9 I can save images fine however they look awful in the program and I'm unable to properly edit them.

Below is the same image Saved with Directx9,10, and 11.
https://www.dropbox.com/s/5u8z5f5h7y5kvkl/Test%20Dx9.bkd?dl=0
https://www.dropbox.com/s/jjp47vpbms6b6j5/Test%20Dx9.png?dl=0
https://www.dropbox.com/s/7wyd65yvmhnzxty/Test%20Dx10.bkd?dl=0
https://www.dropbox.com/s/vl9nro2bjmr9x3d/Test%20Dx10.png?dl=0
https://www.dropbox.com/s/9kdg15ioxj1wpw9/Test%20Dx11.bkd?dl=0
https://www.dropbox.com/s/3xos1hpqguw673g/Test%20Dx11.png?dl=0

If there is anything else I can deliver to help us solve this problem please let me know!

User avatar
u2bleank
 
Posts: 903
Joined: 11 Jun 2012, 10:41

Re: GPU rendering issues???

Postby u2bleank » 06 Jun 2016, 08:26

Yes it's a really weird know issue.
Because we didn't encounter such problem at the release of Black Ink and then it's "poppe"d ( probably due to Driver problem or incompatiblity with something ). So we have to test on different hardware because we doesn't reproduce with our office computers.
Anyway it's something that we will fix for the next Black Ink Release.
A possible workaround for now is to merge all your layers before doing your Save ( tell us if it works for you ).
And sorry for that.

User avatar
jakekulp
 
Posts: 5
Joined: 06 Sep 2013, 22:27

Re: GPU rendering issues???

Postby jakekulp » 06 Jun 2016, 18:40

Merging the layers has solved this issue for DX11 on my machine. Thanks for the feedback!

eternalwhitemoon
 
Posts: 7
Joined: 11 Sep 2013, 03:38

Re: GPU rendering issues???

Postby eternalwhitemoon » 22 Nov 2016, 13:47

I have the same problem, although not all the time:

http://imgur.com/a/qikk0
http://imgur.com/a/ktysB

If it helps for bug squashing, here are some relevant hardware stats:

-Core i7 3930k processor
-ASUS P9X79LE motherboard
-32 GB of RAM
-2x Radeon HD7950 cards in CrossFire
-Windows 10 Pro, build 1607

This issue occurred as recently as last night.

Merging the layers works, but even though I save it as png, the file properties still show it as a zero byte file without an extension. Yet, if I tell it to open with something like Paint it will still do it.

http://imgur.com/a/J9Bam

User avatar
u2bleank
 
Posts: 903
Joined: 11 Jun 2012, 10:41

Re: GPU rendering issues???

Postby u2bleank » 22 Nov 2016, 13:54

it should be fixed with the next update


Return to Technical support