Issues with v0.115.1500 (D3D10)

Discuss features and report problems with BlackInk
clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Issues with v0.115.1500 (D3D10)

Postby clayton » 30 May 2013, 18:40

Hello,

I have a couple of issues with this version:

1) Start Black Ink (1920x1080) and zoom right out. Picked any brush and started painting. Then zoomed right in and as the canvas gets closer, the orginal white background is displayed before refreshing the contents
2) I then zoom in and out and it is not smooth but very choppy and I have only painted one stroke.

Did not have these problems in the previous version.



Clayton

User avatar
u2bleank
 
Posts: 1011
Joined: 11 Jun 2012, 10:41

Re: Issues with v0.115.1500 (D3D10)

Postby u2bleank » 30 May 2013, 20:11

Hi Clayton,

what is your GPU ( is it still a nVidia Geforce GT 9600 graphics card ) ?
Are those problems constant over time when you use BI or is it something who only occur for your first paint stroke ?
In the previous version ( 0.114 ) did you have experienced some flickering for the canvas when zooming and panning ?

Cheers.

clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Re: Issues with v0.115.1500 (D3D10)

Postby clayton » 30 May 2013, 21:25

Hi,

Yes, it's exactly the same setup.

Haven't had enough time to play, but mostly I would say at the start. Will confirm though.

I did not notice any flickering and the positioning of the canvas at the start (in the previous version) is now fixed and working well.

One other thing that may help is that when I was painting outside of the canvas (wet ink), you could see squares before refreshing.


I will do some more testing, however I am on holiday for two weeks on the weekend. I will then continue testing when I get back from holiday.



Clayton

clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Re: Issues with v0.115.1500 (D3D10)

Postby clayton » 30 May 2013, 21:32

At Startup:

Zoomed right out - Calligraphic Pen and filled the canvas. Zoomed right in and the canvas now displays white (original background colour). Waited about 10 or so seconds for graphics card to update. Then zoomed out, very choppy. Chose the dots default (whilst zoomed out) and it was very slow when painting.

Then I waited for a bit (typing this message !!) and then zoomed in and out - No refresh issues !!! It also seems smoother at this point as well.

EDIT: Added a Volute and zoomed in and out - mostly smooth. When zoomed right in though it takes about 10 seconds to refresh (it's almost like watching a 3D renderer) as it renders each block. This happens throughout the session and not the just the start. Definitely did not have this in the previous version.


Clayton

User avatar
u2bleank
 
Posts: 1011
Joined: 11 Jun 2012, 10:41

Re: Issues with v0.115.1500 (D3D10)

Postby u2bleank » 31 May 2013, 08:04

Hi clayton,

Many thanks for your help.
Can you please send us your log file ( here the procedure and we don't need the .dmp ).

Cheers

clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Re: Issues with v0.115.1500 (D3D10)

Postby clayton » 16 Jun 2013, 20:57

Hello,

Sorry for the late reply on this one, just got back from holiday.

Testing v0.117.1504 (D3D10) and still having the same issues as above.

I have tested the above with no other applications running.

One thing that I have noticed is that once I zoom out, apply a brush stroke, zoom back in a little the canvas turns white and then it block renders the canvas. If I zoom in a little more, the same thing happens until I cannot zoom in anymore. Then it seems OK, I can zoom in and out not problem until I apply another stroke.


Hope this helps,


Clayton

User avatar
u2bleank
 
Posts: 1011
Joined: 11 Jun 2012, 10:41

Re: Issues with v0.115.1500 (D3D10)

Postby u2bleank » 18 Jun 2013, 07:48

hi clayton,

Thanks for the report.
Unfortunately :cry: I can't fix your problem before the next release of BlackInk ( who will be scheduled on July )

Regards

clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Re: Issues with v0.115.1500 (D3D10)

Postby clayton » 18 Jun 2013, 20:16

Hi,

That's OK.

So are you saying that you know what the problem/fix is ?



Clayton

User avatar
u2bleank
 
Posts: 1011
Joined: 11 Jun 2012, 10:41

Re: Issues with v0.115.1500 (D3D10)

Postby u2bleank » 19 Jun 2013, 08:15

Hi clayton,

So are you saying that you know what the problem/fix is ?


Not really, you have the only configuration where the performance at worst after the new version.
Performance are better on all other config we have tested on.
But it's probably related to how GPU handles textures. I will perhaps grant you access to the debug panel of BlackInk ( if you want ) for the next release, so we will see how it is going on and try to fix the problem.

Cheers

clayton
 
Posts: 30
Joined: 27 Dec 2012, 15:36

Re: Issues with v0.115.1500 (D3D10)

Postby clayton » 19 Jun 2013, 13:28

Hi,

Many thanks for this, let's see how the next version goes first and proceed from there.



Clayton


Return to Technical support